MTS Forum Forum Index
Discussion forum for Synergy, Egnater & Randall MTS Amps & Modules
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Search found 41 matches
MTS Forum Forum Index
Author Message
  Topic: FS: RM22 AMP
warmachine67

Replies: 4
Views: 223

PostForum: Classifieds   Posted: Mon Feb 12, 2018 10:05 am   Subject: FS: RM22 AMP
[quote="keg8605"]Wow did not know about this one. Pretty cool. Is it possible to modded to dual channel?[/quote]

No, single channel only. It has no midi functionality either.
  Topic: RM50 suddenly not working? Any help?
warmachine67

Replies: 29
Views: 465

PostForum: Egnater / Randall Modular Amps   Posted: Thu Feb 08, 2018 12:15 pm   Subject: RM50 suddenly not working? Any help?
Thanks for posting what happened.

Glad you got it worked out.
  Topic: RM50 suddenly not working? Any help?
warmachine67

Replies: 29
Views: 465

PostForum: Egnater / Randall Modular Amps   Posted: Tue Jan 30, 2018 3:34 pm   Subject: RM50 suddenly not working? Any help?
If you think about, let us know what it was.

I'm still curious. Congrats on the synergy btw.
  Topic: RM50 suddenly not working? Any help?
warmachine67

Replies: 29
Views: 465

PostForum: Egnater / Randall Modular Amps   Posted: Sat Jan 27, 2018 6:36 pm   Subject: RM50 suddenly not working? Any help?
Mattfig,

I'm curious, what exactly do those internal fuses do in broad terms?

I've always wondered. Are there 4 or 5?

Thanks !
  Topic: RM50 suddenly not working? Any help?
warmachine67

Replies: 29
Views: 465

PostForum: Egnater / Randall Modular Amps   Posted: Sat Jan 27, 2018 6:22 pm   Subject: RM50 suddenly not working? Any help?
Don't do this if you are unsure or feel unsafe.

Leave the standby switch on and turn the amp off. This will drain the capacitors. Then just leave it unplugged for a few minutes and then you shoul ...
  Topic: RM50 suddenly not working? Any help?
warmachine67

Replies: 29
Views: 465

PostForum: Egnater / Randall Modular Amps   Posted: Sat Jan 27, 2018 5:33 pm   Subject: RM50 suddenly not working? Any help?
Guess you have some spare 12ax7s to try in v1 and v2? Probably the same result.

I'd have to see a schematic if the internal fuses are ok before I could even begin to guess what next.
  Topic: RM50 suddenly not working? Any help?
warmachine67

Replies: 29
Views: 465

PostForum: Egnater / Randall Modular Amps   Posted: Sat Jan 27, 2018 5:20 pm   Subject: RM50 suddenly not working? Any help?
I seem to remember there are four small fuses on the power switch side of the chassis hidden when it is boxed. I am not sure what they do.

At least it still makes sound Smile and it seems your OT is ...
  Topic: Soldano Flavours?
warmachine67

Replies: 8
Views: 346

PostForum: Synergy Amps & Modules   Posted: Sat Jan 27, 2018 5:01 pm   Subject: Soldano Flavours?
I seem to remember there was a post with a YouTube video a/b'ing a synergy slo to a jf slo100od.

They seemed to sound different in the video and then jf got bashed a little bit in the post comment ...
  Topic: RM50 suddenly not working? Any help?
warmachine67

Replies: 29
Views: 465

PostForum: Egnater / Randall Modular Amps   Posted: Sat Jan 27, 2018 4:56 pm   Subject: RM50 suddenly not working? Any help?
Maybe someone else will chime in, but aren't some internal fuses hidden inside an Rm50?

I'm guessing you tried plugging the speaker back in? Was there any hum with the speaker plugged in?

Was th ...
  Topic: Soldano Flavours?
warmachine67

Replies: 8
Views: 346

PostForum: Synergy Amps & Modules   Posted: Sat Jan 27, 2018 8:15 am   Subject: Soldano Flavours?
Thanks the comparing them. Hope you will update us after you have more time with them.

So it sounds like on the synergy slo that the red and blue channels are practically the same voicing?

Do ...
  Topic: Motor City Mods....
warmachine67

Replies: 6
Views: 412

PostForum: Rigs & Tones   Posted: Sat Jan 27, 2018 7:31 am   Subject: Motor City Mods....
When will the new MTS mods that Antonin has been teasing lately show up on motorcitymods?
  Topic: Synergy VH4 Issue (resolved) - MID pot faulty confirmed
warmachine67

Replies: 19
Views: 728

PostForum: Synergy Amps & Modules   Posted: Mon Jan 01, 2018 7:30 am   Subject: Synergy VH4 Issue (resolved) - MID pot faulty confirmed
I've been considering getting into the synergy stuff this upcoming year, but if this is how they handle their customers, I'll just stick with what I have.
  Topic: What do I bias KT 77 tubes at?
warmachine67

Replies: 5
Views: 443

PostForum: Egnater / Randall Modular Amps   Posted: Sat Dec 16, 2017 9:50 pm   Subject: What do I bias KT 77 tubes at?
You can bias them like regular EL34's, but they will be running a little cool.

I ran some kt77's for a while and I think my research turned up 35-40mV so that's what I set them at and they seemed ...
  Topic: Synergy VS Egnater : cathode switch
warmachine67

Replies: 34
Views: 2269

PostForum: Synergy Amps & Modules   Posted: Tue Dec 05, 2017 1:08 pm   Subject: Synergy VS Egnater : cathode switch
Interesting reply, thanks for explaining that Rob.

Are the folks from Synergy eventually going to make a presence on this board? I'm sure they are busy getting the new product out there, but seem ...
  Topic: anyone know about trannies? in the RT2/50?
warmachine67

Replies: 16
Views: 919

PostForum: Egnater / Randall Modular Amps   Posted: Wed Oct 11, 2017 8:05 am   Subject: anyone know about trannies? in the RT2/50?
Rob,

Can u speak for what you have seen in the rm1250's.

Are they Chinese made like the rm50 or something else?

Great stuff. Thanks!
 
Page 1 of 3 Goto page 1, 2, 3  Next
All times are GMT - 6 Hours
Jump to:  


Powered by phpBB © 2001, 2005 phpBB Group