Page 1 of 1

Can't get on site using IE, can using chrome..

Posted: Fri Mar 06, 2015 6:47 am
by warlok
When I try to get on the site using IE version 10 I think (work PC) I get this:
Fatal error: Call to undefined function: str_split() in /home/grailton/public_html/mtsforum/index.php(1) : regexp code(1) : eval()'d code(1) : regexp code on line 1
I can access it using chrome and this is the only site that has this problem.
Any ideas??

Posted: Fri Mar 06, 2015 7:44 am
by tschrama
been that way for weeks allready. I'm using firefox since...

Posted: Sun Mar 08, 2015 6:11 pm
by ned
Made some changes. Let me know if the problem persists.

Ned

Posted: Mon Mar 09, 2015 1:14 am
by tschrama
Problem is still there with IE:

"Fatal error: Call to undefined function: str_split() in /home/grailton/public_html/mtsforum/viewtopic.php(1) : regexp code(1) : eval()'d code(1) : regexp code on line 1"

With Firefox there is no problem at all.

Posted: Mon Mar 09, 2015 6:25 am
by warlok
Yeah, still no good using IE for me too.

Posted: Mon Mar 09, 2015 6:44 am
by suphuckers
Fatal error: Call to undefined function: str_split() in /home/grailton/public_html/mtsforum/common.php(1) : regexp code(1) : eval()'d code(1) : regexp code on line 1


Same for me

Posted: Mon Mar 09, 2015 5:49 pm
by ned
Made more changes. Let me know if there are more issues.

Posted: Mon Mar 09, 2015 5:57 pm
by suphuckers
Fatal error: Call to undefined function: str_split() in /home/grailton/public_html/mtsforum/includes/constants.php(1) : regexp code(1) : eval()'d code(1) : regexp code on line 1

Posted: Tue Mar 10, 2015 1:02 am
by tschrama
Sorry, still the same error in IE.

Posted: Tue Mar 10, 2015 6:41 am
by warlok
me too.

Posted: Tue Mar 10, 2015 8:15 am
by MarcoR
IE 11 has caused some issues with some of my web applications and forcing emulation mode has worked in some cases. I thought I'd check here but it did not make a difference.

However, for a workaround, if you want to use IE with this site, hit F12 or go to Tools > F12 Developer Tools > Emulation and change "User agent string" to Google Chrome or Opera. Then you will not get the error.

I'm not a PHP developer otherwise I could tell Ned how to fix it. :(

edit: A quick google search turns up lots on this error. "str_split() is only available in PHP5, so I suspect the problem is you're running PHP4.x. Try using explode() instead."

Ned, what version of PHP are you running?

Posted: Wed Mar 11, 2015 7:58 am
by ned
Site is running php 4.x

I keep debating about upgrading the server but it's a crap ton of work since much of the code will need to be re-written for PHP 5. The forum upgrade is the easy part.

Posted: Tue Jul 07, 2015 7:58 am
by SickPunk
Still can't get to the page with IE 11.