Hello. Another RM4 fizzing out......

Discussion for both Egnater & Randall modular amps

Moderators: guitarguy510, ned

Post Reply
Modulartothemax
RM20
Posts: 6
Joined: Fri Sep 22, 2017 12:02 pm

Hello. Another RM4 fizzing out......

Post by Modulartothemax » Fri Sep 22, 2017 12:10 pm

Hello everyone. I pulled my RM4 out of storage where it has been for a few years and it seems to be a real mess. I have done some searches and and tried a few things so I am hoping someone can help. When I turn it on it sounds like it is not receiving full power. If I turn the gain down on a module it distorts and sounds fuzzy and cuts out almost like there is a noise gate on the guitar signal. I have tried a few things like using contact cleaner on all of the jacks. Another scary thing is if I mess with the gain knob on one module it affects the other. And the channel switching button is not working. If anyone has any suggestions I would appreciate it. I am not afraid to try anything, otherwise if anyone knows a good repair person in Europe it would be greatly appreciated.

withmittens
Lynch Box
Posts: 1103
Joined: Sun May 13, 2012 12:37 pm
Location: Beacon, NY
Contact:

Post by withmittens » Fri Sep 22, 2017 12:35 pm

try fresh tubes. Other than that your probably right in contact cleaner on everything as it may have taken on humidity while in storage. open it up and make sure everything is clean
RM22, RM4
CrazyNuts' Dirty Sanchez, DuoPlex, Selma, Supra, Twinface, Evil Kitty, CC30, XTC
SG, LP Std., Strat, TELE

Modulartothemax
RM20
Posts: 6
Joined: Fri Sep 22, 2017 12:02 pm

Post by Modulartothemax » Fri Sep 22, 2017 2:05 pm

Thanks for the reply. I did switch out the 3 preamp tubes. The scary thing is that the channels seem to be bleeding. Tried getting it to switch midi but no luck.

galao
Donating Member
Posts: 126
Joined: Fri Dec 05, 2008 1:08 pm
Location: Berlin, Germany

Post by galao » Fri Sep 22, 2017 2:44 pm

Sounds like a defective MIDI board or an issue with the power supply going to the MIDI board.
DUAL CHANNEL MODS
https://yuneo.de

Modulartothemax
RM20
Posts: 6
Joined: Fri Sep 22, 2017 12:02 pm

Post by Modulartothemax » Fri Sep 22, 2017 3:07 pm

Hmmmmm. Maybe I will have to order one of those 2 channel midi board from you and fix it the right way?????

galao
Donating Member
Posts: 126
Joined: Fri Dec 05, 2008 1:08 pm
Location: Berlin, Germany

Post by galao » Fri Sep 22, 2017 3:19 pm

Where are you located?
DUAL CHANNEL MODS
https://yuneo.de

galao
Donating Member
Posts: 126
Joined: Fri Dec 05, 2008 1:08 pm
Location: Berlin, Germany

Post by galao » Fri Sep 22, 2017 3:39 pm

This is a job for a tech. It doesn´t make sense to replace the board if i.e. there is a short, a defective voltage regulator or another problem that is not located on the board itself.
DUAL CHANNEL MODS
https://yuneo.de

Modulartothemax
RM20
Posts: 6
Joined: Fri Sep 22, 2017 12:02 pm

Post by Modulartothemax » Fri Sep 22, 2017 4:01 pm

I am in England. The scary thing is their is bleeding through the modules as well. The sound from one is going into another.. Almost as if a channel isn't selected.....

galao
Donating Member
Posts: 126
Joined: Fri Dec 05, 2008 1:08 pm
Location: Berlin, Germany

Post by galao » Fri Sep 22, 2017 4:15 pm

If there is a voltage on two or more wires coming from the pic controller on the MIDI board it may happen that you hear them simultaneously as all audio outs are in parallel with each other. If you say that neither the front switch nor the MIDI in work, I´m sure that there must be something wrong in the area of the MIDI board.
DUAL CHANNEL MODS
https://yuneo.de

Modulartothemax
RM20
Posts: 6
Joined: Fri Sep 22, 2017 12:02 pm

Post by Modulartothemax » Fri Sep 22, 2017 6:51 pm

Thank you so much for the reply. I will be in touch..

tschrama
RM100
Posts: 207
Joined: Wed Jun 04, 2014 1:32 pm
Location: Netherlands

Post by tschrama » Sat Sep 23, 2017 12:40 am

Pretty sure it's is a power supply issue playing havoc on the optocouplers. At least that would explain your symptoms.

If you can't get it fixed, I will be glad to have a look. I'm in the Netherlands, so it might not be convenient, but I have experience with servicing Randall MTS equipment.
my small atelier called 's-Gravenmade | Follow me www.sgravenmade.com | Join my Amp Building Workshop 14 april 2018

Good deals with: C2ply, BenMesaBoog, YouguitarHero, nitrous12, kylendm.

Modulartothemax
RM20
Posts: 6
Joined: Fri Sep 22, 2017 12:02 pm

Post by Modulartothemax » Sat Sep 23, 2017 12:02 pm

Thank you for the message. I will certainly consider it. I suppose it is worth resurrecting.

Post Reply