After a while my rm50 combo loses definition...

Discussion for both Egnater & Randall modular amps

Moderators: guitarguy510, ned

Post Reply
GtrGeorge!
Lynch Box
Posts: 1672
Joined: Wed Aug 22, 2007 8:30 pm

After a while my rm50 combo loses definition...

Post by GtrGeorge! » Fri Mar 12, 2010 4:35 am

whats up with that? Anybody notice this with their amp?
the first hour is good...but after an hour my tone gets a little sloppy, a little "bratty" if that description makes sense,(and loose ) i am using a Plexi module and a Ultra,into celestion V30. Volume is like 60percent. using passive pickups.
i dont get it.
Any clues??????????????

m0jo
Donating Member
Posts: 1892
Joined: Mon Sep 29, 2008 2:07 pm
Location: The Netherlands

Post by m0jo » Sun Mar 14, 2010 3:53 am

Old tubes maybe?
Does the tone get duller?

Maybe try letting it stand on for an hour and checking wether it does the same then..
Of you play at very loud levels it might be your ears fatigueing .. but you can be th ebest judge of that.

Salvation Mods Twinface, Mash-all+, Sloogie, Mu?eca, Shiver (Facelift), modded XTC, stock Recto
Randall RM4 - Randall RT2/50 - Randall RM22
TT-Cabs REX V212


www.sparkplugmusic.nl

isburgracing
RM50
Posts: 69
Joined: Fri Jan 22, 2010 7:48 am

Post by isburgracing » Sun Mar 14, 2010 9:09 am

I agree with the ears fatiguing thing, after bout an hour of loud playing, especially with a band, your ears get tired. And I start hearing different things.
Randall RM100m head
Randall 4x12 cab Eminence
Marshall 4x12 cab Celestion
Randall RM100 2x12 Combo
Ultra, Ultra XL, 1086, Blackface, Modern, SL+
Edwards LP Custom EMG 81 85
Washburn Nuno Dimarzio Deactivator X
ESP Eclipse SD Blackouts

GtrGeorge!
Lynch Box
Posts: 1672
Joined: Wed Aug 22, 2007 8:30 pm

Mojo..and others

Post by GtrGeorge! » Mon Mar 15, 2010 9:22 pm

it doesnt get duller ....it gets more crappy..like it went from a full fidelity to a lesser fidelity. I dont think my ears are fatiguing. My guys play damn loud..but I do get far away from them and I also use hearing protection all the time.
So what could it be?

Shinozoku
Lynch Box
Posts: 1340
Joined: Mon Nov 17, 2008 1:48 pm
Location: Bristol, VA

Post by Shinozoku » Tue Mar 16, 2010 3:42 pm

My RM100 is doing this actually. Used to be bright and clear, but now it's only like that through my friend's Marchall cab with G1275's. It's far too soft sounding on my Vader now... And this is with a new set of EL34's!
RM100M w/ Tung Sol 5881's
Blackface(self modded), Ultra Lead, SL+(out of commission), Ultra XL (self modded)
Vader 2x12 Cab
Edwards E-AL-128 with a Seymour Duncan JB

goldsparkletop
RM100
Posts: 144
Joined: Sun Mar 05, 2006 4:24 pm
Location: Virginia

Post by goldsparkletop » Thu Mar 18, 2010 12:27 am

My rig gets significantly brighter as the night goes on. Not a little bit, SIGNIFICANTLY. I try to adjust the presence on my power amp to compensate, but it's a pain in the ass, nonetheless.

I don't know if it's my RM4 or the VHT power amp that's to blame. I've changed the power tubes a few times with no apparent impact to this phenomena. I have never changed the preamp tubes in the power amp, though.

:?:
Randall RM4
VHT 2/50/2
Blackface, Plexi, Recto, 1086, Ultra Lead modules
Rocktron Xpression
www.krunchband.com

MegaGoo
RM100
Posts: 117
Joined: Thu Jan 21, 2010 2:10 am

Post by MegaGoo » Thu Mar 18, 2010 6:00 pm

i think this happens with my 5150 although i didnt happen to notice last time i played it (before that it had been a while). power tubes are very very worn. preamp tubes arent in great shape either

GtrGeorge!
Lynch Box
Posts: 1672
Joined: Wed Aug 22, 2007 8:30 pm

Im still trying to figure it out

Post by GtrGeorge! » Thu Mar 18, 2010 11:12 pm

Im still trying to figure it out...
maybe the parts heat up and react different. Any advice is welcome.

Post Reply