RM100SI: issue with modded modules

Area specific for Lynch, Hammett, Donagan (1086), etc modules and amps

Moderators: guitarguy510, ned

Post Reply
speed2dirt
RM100
Posts: 268
Joined: Thu Jan 26, 2012 11:14 am
Location: La Habra, CA

RM100SI: issue with modded modules

Post by speed2dirt » Mon Oct 01, 2012 11:54 am

I just picked up a brand new in box Randall RM100SI head this weekend. The stock mods sound great in this head. However, all my modded modules sound way too ear piercing. There's some high frequency that cannot be tuned out and almost makes me feel like my ear is going to bleed. Weird.

All those modded modules (see sig) sound great in my RM20 head. Both are using the same cabs and everything. Is the issue just EL84s vs EL34s? Or is it something with the amp? I have noticed the presence knob doesn't seem to make much difference, but then again, by the time I started messing with the presence knob my ears were already shot. I just don't get how the stock mods don't have the issue but all the modded ones do. Any ideas?
Jaded Faith: Wrecked|1959RR Platinum|Pitbull|Custom KH3|UltraLead|DamagePlan
Sacred Groove: Fisch|XTC LE|Afterlife|Numskull

JayDA
Lynch Box
Posts: 1065
Joined: Sun Dec 31, 2006 5:12 pm
Location: Dirty Jersey

Post by JayDA » Mon Oct 01, 2012 12:07 pm

When I got my Ian head, the tubes were biased wayyyyyy to high out of the box, not sure if this could be the cause of your problem...but I just thought I'd throw it out there.

Oregon
Lynch Box
Posts: 537
Joined: Tue Jul 10, 2012 3:01 pm
Location: Oregon

Post by Oregon » Mon Oct 01, 2012 1:34 pm

+1 for that biasing comment.
RM4, RT2/50, LynchBox Combo

speed2dirt
RM100
Posts: 268
Joined: Thu Jan 26, 2012 11:14 am
Location: La Habra, CA

Post by speed2dirt » Tue Oct 02, 2012 9:24 am

I checked the bias last night. The tubes ranged from 29.5 - 34.5, a couple of which were below range for EL34s. I adjusted them all to about 35, but the problem still persists.

The issue could be speaker related, I guess. I have two Bogner Cubes loaded with Vintage 30s. I noticed the Scott Ian cab is loaded with Heritage 30s. I'm wondering if the power difference between the RM20 and the RM100SI is making the speakers react differently. I don't have either amp up loud, just to where the speaker comes to life and begins to open up. This really is perplexing though. I wish I would have brought my modded modules to the store and tried them with their demo RM100SI. That would have answered some questions. Too bad the store is about an hour away. Any other ideas?
Jaded Faith: Wrecked|1959RR Platinum|Pitbull|Custom KH3|UltraLead|DamagePlan
Sacred Groove: Fisch|XTC LE|Afterlife|Numskull

speed2dirt
RM100
Posts: 268
Joined: Thu Jan 26, 2012 11:14 am
Location: La Habra, CA

Post by speed2dirt » Thu Oct 04, 2012 9:33 am

I messed with the stock modules last night and they have the same high frequency issue. I think when I first played the RM100SI, the volume was lower which masks the issue.

Really, the issue sounds like the Presence is stuck wide open. I can adjust the knob, but it doesn't really change the top end. Is it even possible for the Presence to somehow be fully on regardless what position the knob's in? If so, what would cause that and how do I fix it?
Jaded Faith: Wrecked|1959RR Platinum|Pitbull|Custom KH3|UltraLead|DamagePlan
Sacred Groove: Fisch|XTC LE|Afterlife|Numskull

Mike361
RM100
Posts: 324
Joined: Sun Apr 27, 2008 10:18 am
Location: MI.

Post by Mike361 » Wed Oct 10, 2012 8:41 am

if you haven't already, post this in the amp section. Might get more help. It sounds like a presence board problem or tube's. Not sure. Hard to comment on sound issues without actually hearing them. Vintage 30's are not known to be high freq. speakers. I would try to eleiminate all you can then go from there. Try new speakers, try different tubes. if possible. Then talk to Rob at Jaded faith. Very well could be the presence board.
RM50B
Rm50H
1086
Blackface
1959rr plat
Pete modded SL+
Super V

crankyrayhanky
Lynch Box
Posts: 3417
Joined: Thu May 08, 2008 7:34 am
Contact:

Post by crankyrayhanky » Wed Oct 10, 2012 9:46 am

a lot of these variables you're looking at should NOT give you the total CRAP piercing tone you describe....sounds like an issue with the head/presence :cry:

speed2dirt
RM100
Posts: 268
Joined: Thu Jan 26, 2012 11:14 am
Location: La Habra, CA

Post by speed2dirt » Wed Oct 10, 2012 11:10 am

Thanks for the response, guys! I ended up returning it this past weekend. At the store, they fired it up so they could hear the issue (they're an authorized Randall service center). Within 2 minutes, they noticed the presence had no affect on tone and then it blew. Literally, a loud pop like someone unplugged the guitar and then nothing. The tube failure lights didn't signify it was a power tube failure. I'm just glad that happened at the shop and not at home. Anyway, they let me borrow the demo until they can get another new one shipped from Randall.

Let me just say, the tone is so much better. I can't believe I kept messing with it thinking it was speakers, guitar, etc.
Jaded Faith: Wrecked|1959RR Platinum|Pitbull|Custom KH3|UltraLead|DamagePlan
Sacred Groove: Fisch|XTC LE|Afterlife|Numskull

gag halfrunt
Lynch Box
Posts: 644
Joined: Mon Jul 27, 2009 9:14 am
Location: Marquette, Michigan

Post by gag halfrunt » Wed Oct 10, 2012 11:38 am

Congrats on getting to the bottom of it. It's so great to hear these modded modules in all their glory.
My Band's website (I'm Bill, the lead guitarist): www.impossibletuesday.com/about.html

Kemper into Atomic CLR neo.

Downrightproductions
RM50
Posts: 83
Joined: Mon Jan 09, 2012 10:16 am

Post by Downrightproductions » Wed Oct 31, 2012 6:09 pm

Ya, even I know I'm late to comment, it was a deffinate problem....my presense on my rm100si totally works....was it new or used you got it from? In working order it is sick, just like all the RM's....but its just that much cooler!....hope you are gonna get it back to rock! There are few of us out there that have one! No modded modules yet cuz I got this versus one I could have grabbed cheap and bought extra modules....its a show stopper!!!!!

Post Reply