MTS Forum Forum Index
Discussion forum for Synergy, Egnater & Randall MTS Amps & Modules
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

RG75G3 hum

 
Post new topic   Reply to topic    MTS Forum Forum Index -> Other Randall Amps
View previous topic :: View next topic  
Author Message
harrywwc
RM20


Joined: 25 May 2007
Posts: 4
Location: NSW, Australia

PostPosted: Fri May 25, 2007 10:34 pm    Post subject: RG75G3 hum Reply with quote

Hi guys,

brand new to Randall Amps, received my first yesterday - RG75G3.

Anyway, when I turn it on, there is a hum at about 50Hz. I'm in Oz (240V / 50Hz) so it appears to be 'power related'.

Hum is there even when nothing is connected, not even the footswitch, and all controls are set to '0'. There is a "Ground / Lift" switch on the back. The hum appears not to diminish in either position.

It is 'less noticible' when I am playing, but in quiet passages, it is definitely still there.

Any pointers / suggestions? Or is this DoA?

kind regards,

Harry
_________________
Gibson Les Paul Recording (1973)
Randall RG75G3 (2007)
Back to top
View user's profile Send private message
rasweb
RM20


Joined: 28 May 2007
Posts: 3

PostPosted: Mon May 28, 2007 6:33 am    Post subject: Hum Reply with quote

I am having same problem with my new RH300G3 with matching 4x12 cab.

I bought it less than two weeks ago and it was humming pretty much as soon as I got it home. I took it back to the shop and they were not getting the hum at all!

I think mine is power related, I think the best way to test is to take it to a friend's house in another suburb which I am trying this week.

I have tried changing all cables and moving the half-stack to diff rooms in my house but it doesn't make any difference.

BTW, I contacted Randall and they advised I return it as it "could be caused by a variety of mechanical faults"... but like i said, the shop was not experiencing the problem.
Back to top
View user's profile Send private message
harrywwc
RM20


Joined: 25 May 2007
Posts: 4
Location: NSW, Australia

PostPosted: Mon May 28, 2007 3:03 pm    Post subject: Reply with quote

Hi Rasweb,

thanks for your reply - I appreciate it.

I've already tried the 'go to another suburb and test it there' bit ;'/

My church is about 20 mins drive away, so I am pretty sure that it is in the amp itself, and not related to 'dirty' power.

I mean, I expect "some" hum from the equipment, I just didn't expect it to be audible at about 12 feet away - one of the vocalists complained about it :'(

{sigh} I know Randall have read my message (Read Receipt), but nothing else so far.

Thanks once again,

.h
_________________
Gibson Les Paul Recording (1973)
Randall RG75G3 (2007)
Back to top
View user's profile Send private message
rasweb
RM20


Joined: 28 May 2007
Posts: 3

PostPosted: Mon May 28, 2007 6:48 pm    Post subject: Reply with quote

Hi

That's disappointing to hear, considering this is my last hope (dirty power).

I Hope you have better luck with randall support than I did. I will post reply if I find anything else useful... Feel free to let me know if you have a useful response from randall support Smile
Back to top
View user's profile Send private message
harrywwc
RM20


Joined: 25 May 2007
Posts: 4
Location: NSW, Australia

PostPosted: Tue May 29, 2007 11:20 pm    Post subject: it's DoA Reply with quote

Just an update,

I sent mail to both Randall and the distributor here in Oz - and of course it was a long weekend in the US - the story of the week so far :'/

Anyway, both got back to me and said that it sounds like it's 'dead' and needs to be replaced.

I contacted the store I bought it from (Venuemusic.com.au - plug, plug) and while I was seeking to have it repaired, they have insisted that it be replaced, will unpack one, test it in store to ensure no fault, and ship it to me, pick up the 'dud' and take it away.

Now, in the US you may expect (nay *demand*) service like this, but in Oz this is just mindblowing!. Service like this is almost unheard of in this country.

Pleasently delighted,

harry
_________________
Gibson Les Paul Recording (1973)
Randall RG75G3 (2007)
Back to top
View user's profile Send private message
metalmm785
RM100


Joined: 31 Jul 2006
Posts: 260
Location: NJ

PostPosted: Tue May 29, 2007 11:50 pm    Post subject: Reply with quote

Congrats!! and sweet of them to make it right! Enjoy the new amp man.
Back to top
View user's profile Send private message Send e-mail
custom_elect
RM20


Joined: 12 Jul 2007
Posts: 3

PostPosted: Thu Jul 12, 2007 9:12 am    Post subject: Reply with quote

Seems several people on here - Me included, have got this same problem with G3s
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    MTS Forum Forum Index -> Other Randall Amps All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group