Egnater Mod 50 trouble shooting

Discussion for both Egnater & Randall modular amps

Moderators: guitarguy510, ned

Post Reply
k9blek
RM100
Posts: 286
Joined: Sat Mar 27, 2010 6:55 am
Location: St. Louis
Contact:

Egnater Mod 50 trouble shooting

Post by k9blek » Fri Mar 24, 2017 6:03 am

I just picked up a Mod 50 in a trade with a dual module. I played it for about 5 minutes or so (on the low power setting) and the sound went out. I switched it to stand by and tried the "high power" side. Nothing. Switch out cables and tried a new cabinet. nothing. I shut it off and then turned it back on after a few minutes to the "high power" section and it worked fine for a few minutes. I switched it to the low power setting and it worked for about 10 seconds before going out again. Tried to switch back to high power. Nothing. Any ideas would be appreciated. Thanks.
RM22/100BP-JF Legato/PlexiTweed/Silverado - Good deals: schlagdog, khingpynn, Nitrous, alowerdeep,rlord1974,BIGKAHUNA,ColdMachine, c2ply,RisingFarce,MattFigOldTimer,JimW427,and Kevrock25, L82theParty,Nitrous,

MarcoR
Donating Member
Posts: 897
Joined: Wed May 02, 2007 10:47 am
Location: Frederick, MD

Post by MarcoR » Sat Mar 25, 2017 6:10 am

The serial loop jacks may need a cleaning. Try a short cable from send to return and see if that stops it from cutting out. If so use something like deoxit and spray on the cable plug and work that in/out of each jack.
Synergy: SYN2, Friedman DS, HBE
Self Modded: Egnater B'Man, SL2X
Amps: VHT 2/50/2, RM50, Landry LS100 G3, Splawn Quick Rod, Marshall 6100LM

Jaded Faith
Moderator
Posts: 2711
Joined: Sat Jul 14, 2007 10:25 pm
Location: Hamilton, NJ
Contact:

Post by Jaded Faith » Mon Mar 27, 2017 5:54 am

FWIW, I have repaired a few of those where the High/Low standby switch has failed. I know Bruce had a bad run of them a few years back. Email me if you need help.
www.jadedfaithmods.com
https://www.facebook.com/JadedFaithMods
Email: info@jadedfaithmods.com
Authorized Service Center for US Music and Egnater
Authorized Reseller for Celestion, Scumback & Mercury Magnetics

k9blek
RM100
Posts: 286
Joined: Sat Mar 27, 2010 6:55 am
Location: St. Louis
Contact:

mod 50

Post by k9blek » Mon Mar 27, 2017 1:57 pm

It actually seems to be working again. I'm not sure what happened but I changed the speaker cable out again. Maybe I didn't have it seated right or something? If it acts up again I'll get in contact Rob. Thanks man !
RM22/100BP-JF Legato/PlexiTweed/Silverado - Good deals: schlagdog, khingpynn, Nitrous, alowerdeep,rlord1974,BIGKAHUNA,ColdMachine, c2ply,RisingFarce,MattFigOldTimer,JimW427,and Kevrock25, L82theParty,Nitrous,

forensbro
RM20
Posts: 22
Joined: Tue Nov 14, 2017 9:39 am
Location: Shreveport, LA

Post by forensbro » Tue Nov 21, 2017 6:44 am

New to the forum. Has anybody sent their Randall RM50 to Jaded Faith for MM transformer upgrades?

pipedwho
RM20
Posts: 22
Joined: Fri Aug 20, 2010 4:27 am
Location: Australia

Post by pipedwho » Sat Dec 02, 2017 3:09 pm

MarcoR wrote:The serial loop jacks may need a cleaning. Try a short cable from send to return and see if that stops it from cutting out. If so use something like deoxit and spray on the cable plug and work that in/out of each jack.
This happened on mine too. Symptoms were random intermittent volume drops and cut outs. Sometimes it would work for weeks and then suddenly cut out. Hit the amp and it would be fine again a few more weeks. It got worse over the course of a year, until it happened often enough to diagnose the problem.

As MarcoR said, plugging in a short patch cable in the serial loop send/return fixed it until I was able to properly clean the contacts in the series return jack.

Spencer4hire
RM100
Posts: 212
Joined: Fri Mar 03, 2006 6:07 pm
Location: Camas Washington

Post by Spencer4hire » Sat Dec 02, 2017 4:54 pm

forensbro wrote:New to the forum. Has anybody sent their Randall RM50 to Jaded Faith for MM transformer upgrades?
Yes I have a RM50 head and a RM50 combo that Rob did all of his upgrades to including the transformers. Big improvement over stock other than the extra weight of the heavier iron :lol:

Post Reply