Pete's Big Fuse location and other fix thread

That oh so special place to discuss Pete's (OKstrat) module modifications.

Moderator: okstrat

joeymex
RM20
Posts: 12
Joined: Sat Jan 24, 2009 6:55 pm

Blown fuses midi

Post by joeymex » Wed Sep 09, 2009 12:40 pm

Here is the response I got from Randall but I can't seem to identify properly which one corresponds to the pictures attached by Pete.

TUBE: (4) .400mA amp FAST BLO OR REGULAR YES.

MAIN: (2) 10A TUBE HEATER FUSES

MIDI: 1.5 or 2A.

INLET: 5A

SUPPLY: (2) 1.6 AND (2) 5A


Which ones are the MIDI fuses, the Inlet? and Supply?

PLEASE HELP... I WANT TO FIX THIS S.O.B. WHAT A TERRIBLE DESIGN... WHAT THEY WERE THINKING?? THAT OWNERS LOVE TO PUT THEIR LIVES ON RISK BY SWITCHING FUSES NOT PROPERLY ASSIGNED ???
IT IS REALLY A SHAME... I WENT BACK TO MESA BOOGIE AFTER THIS...
I HAVE NEVER BLOWN A MESA BOOGIE FUSE NOR I HAVE TO TOOK THE AMP APART....
:x :x :x :x :x

JKD
Donating Member
Posts: 4969
Joined: Tue Apr 03, 2007 1:25 am
Location: NorCal

Re: Blown fuses midi

Post by JKD » Thu Sep 10, 2009 12:35 am

joeymex wrote:Here is the response I got from Randall but I can't seem to identify properly which one corresponds to the pictures attached by Pete.

TUBE: (4) .400mA amp FAST BLO OR REGULAR YES. = Externally accesible beneath power tubes

MAIN: (2) 10A TUBE HEATER FUSES = F3 and F4 (1 and 2 on teh diag)?

MIDI: 1.5 or 2A. (I believe this is the big red cylinder pictured on the midi board)

INLET: 5A = externally accessible and next to mains cable

SUPPLY: (2) 1.6 = F1G and F2G (5 and 4 on teh diag) AND (2) 5A = F3G and F4G (6 and 7 on the diag) ?


Which ones are the MIDI fuses, the Inlet? and Supply?

PLEASE HELP... I WANT TO FIX THIS S.O.B. WHAT A TERRIBLE DESIGN... WHAT THEY WERE THINKING?? THAT OWNERS LOVE TO PUT THEIR LIVES ON RISK BY SWITCHING FUSES NOT PROPERLY ASSIGNED ???
IT IS REALLY A SHAME... I WENT BACK TO MESA BOOGIE AFTER THIS...
I HAVE NEVER BLOWN A MESA BOOGIE FUSE NOR I HAVE TO TOOK THE AMP APART....
:x :x :x :x :x
You misunderstand the purpose of fuses...they are there to sacrifice themselves before something either presents a hazard and/or further damage occurs.

If a user is not comfortable servicing an amp then they should give it to a tech.

In the above list, the bias supply (F1 or Fuse 3 in the diag) appears to be missing but it's 250mA fuse I believe.

Have you identified which of teh fuses is defective by using a meter? I've download the cad stuff and can read the values directly if you tell me which of the fuses you have found to be bad...

Please note that you could replace the fuse and it could simply blow again as the condition that caused it is still there...
Synergy - HBE,SLO,VH4,TDLX,Plexi, ENGL,OS,BB/BE
Salvation-Deadplate, Spawn, MarkUS, Dual Salvado+JJ Dirt+Terrier
JF-Dual Erect
Gigmods - Mark
Hilly-Snorkeler
Egnater -COD, ERECT
Randall - Brahma,Scary, Grail, GTO, SuperV

Dirtdog
RM100
Posts: 115
Joined: Fri May 22, 2009 9:50 am
Location: Santa Fe, NM 87507
Contact:

Post by Dirtdog » Wed Sep 30, 2009 11:54 am

If any of you have a schematic it shows the fuse value in the schematics.
It shows that F1 is 1.6Asb, F2 is 1.6Asb, F3 is 5Asb, F4 is 5Asb
A = amp, sb = slow blow
Lefty Carvin 747c
Lefty Jackson DKL
Lefty Ibanez 470L with custom quilted maple fretboard and reverse headstock.
Lefty Warwick Corvette 5 string
Eleven Rack
RM-20
www.myspace.com/ditchdevil

MegaGoo
RM100
Posts: 117
Joined: Thu Jan 21, 2010 2:10 am

Post by MegaGoo » Sat Feb 27, 2010 6:45 pm

any idea what these internal (eternal haha) fuses do? my fx loop is acting funky. visually the fuses look good but i'd need to get them tested as my multimeter continuity function isnt working

Caine
RM100
Posts: 342
Joined: Mon Jul 31, 2006 7:27 pm

Post by Caine » Tue Oct 25, 2016 5:52 pm

JKD wrote:Pete..here's a thought, why not post the Fuse types, sizes and rating.

The only one I know is the external tube fuses:

Glass 5x20mm Fast Blo 250V/400mA (stock was 250 or 315...they now ship with 400)

and main external fuse

50W
Glass 5x20mm Slo Blo 250V/3A (at 100/120V), 1.5A (at 220/240V)

100W
Glass 5x20mm(?) Slo Blo 250V/5A (at 100/120V), 2.5A( at 220/240V)
By "main external fuse" do you mean the one next to the power cord jack? I thought I understood that to be the case until I went to the second page of this thread. On the next page "joeymex" wrote:

"Here is the response I got from Randall but I can't seem to identify properly which one corresponds to the pictures attached by Pete.

TUBE: (4) .400mA amp FAST BLO OR REGULAR YES.

MAIN: (2) 10A TUBE HEATER FUSES

MIDI: 1.5 or 2A.

INLET: 5A

SUPPLY: (2) 1.6 AND (2) 5A

Which ones are the MIDI fuses, the Inlet? and Supply?"

My RM100LB is down and it looks like the fuse, that I would call the "main external fuse" looks fried; the one next to the power cord jack.

Caine
RM100
Posts: 342
Joined: Mon Jul 31, 2006 7:27 pm

Post by Caine » Wed Oct 26, 2016 4:49 pm

Okay, so it's apparently a 4.0 Amp Slo Blo fuse. Hopefully that's correct


http://mtsforum.grailtone.com/viewtopic ... ca7357f001

Caine
RM100
Posts: 342
Joined: Mon Jul 31, 2006 7:27 pm

Post by Caine » Wed Oct 26, 2016 7:53 pm

Nope, not 4.0A slo blo, Rob @JF said it's a fast blow, 5 amp, 250V fuse. The size should be 5x20mm.

Post Reply